Get in touch
Back
Resolved

Server is down

Started , resolved .

Website Services API & Automation Services Profile Management Services Fingerprint Services
Resolved

We’re currently under a targeted DDoS attack.

These attacks aren’t random, they usually focus on platforms that matter.
Our systems are secure, and the team is actively mitigating the disruption.
Sorry for the inconvenience, and thank you for sticking with a product worth attacking.

If the issue still persists, please contact us through live chat so we can better assist you.
- Multilogin Team

Posted .
Created

At this moment, we are experiencing an issue on the server side. We are working really hard to fix it.

Posted .