Get in touch
Back
Resolved

Server is down

Started , resolved .

Website Services API & Automation Services Collaboration Services Profile Management Services Fingerprint Services Billing Services
Resolved

Our service is stable now. Now we only need to unblock users' IPs and then they will be able to use our service normally. Unblocking IPs will be handled by the support team.

Posted .
Created

At this moment, we are experiencing an issue on the server side. We are working really hard to fix it.

Posted .