Get in touch
Back
Resolved

Multilogin X service down

Started , resolved .

Website Services API & Automation Services Profile Management Services
Resolved

We have identified the root cause of the issue. Thanks for your patience!

Posted .
Re-appeared

Some services are down, we already working on bringing everything back

Posted .
Resolved

We have resolved all issues

Posted .
Created

Multilogin X experiences downtime due to CloudFlare outage.

Posted .