Back
Resolved
Resolved
MLX Billing Services are degrated
Started 18 Oct at 02:57pm EEST, resolved 18 Oct at 08:03pm EEST.
Billing Services
Resolved
We are happy to inform you that our team has resolved the issue! Please accept our sincerest apologies for this situation.
Posted 18 Oct at 08:03pm EEST.
Updated
Our team has identified the issue. We are working to fix all recent subscriptions.
Posted 18 Oct at 07:31pm EEST.
Created
Some users may face issues in using Multilogin after renewal their subscriptions. Our team is already aware and is investigating the issue.
Posted 18 Oct at 02:57pm EEST.