Back
Resolved
Resolved
Multilogin X is Down
Started 9 Aug at 09:04am EEST, last updated 9 Aug at 12:56pm EEST.
Website Services
API & Automation Services
Profile Management Services
Updated
We have identified the root cause. Issue is fixed.
Posted 9 Aug at 12:56pm EEST.
Created
Users have trouble logging in to the Multilogin X dashboard, and they can't launch profiles, both via UI and API.
Issue fixed
Posted 9 Aug at 09:04am EEST.