Get in touch
Back
Downtime

Multilogin X Server is down

Started 19 Mar at 02:00pm EET, resolved 19 Mar at 05:00pm EET.

API & Automation Services Collaboration Services Profile Management Services
Resolved

Servers are up again. It was caused by a failure of a hosted component which is independent of us.

Posted 19 Mar at 05:00pm EET.
Created

At this moment, we are experiencing an issue on the server side. We are working really hard to fix it.

Posted 19 Mar at 02:00pm EET.