Get in touch
Back
Resolved

Multilogin proxies are down

Started 10 Feb at 01:22am EET.

Profile Management Services
Created

User cannot launch profiles that use Multilogin proxy. We are working on it.

Posted 10 Feb at 01:22am EET.