Get in touch
Back
Downtime

MLA servers are down

Started 29 Jan at 11:50am EET, resolved 29 Jan at 03:15pm EET.

Profile management
Resolved

We are happy to inform you that our team has resolved the issue! Please accept our sincerest apologies for this situation.

Posted 29 Jan at 03:15pm EET.
Created

At this moment, we are experiencing an issue on the server side. We are working really hard to fix it.

Posted 29 Jan at 11:50am EET.