Back
Degraded

Login issue in Multilogin 6
Started 27 Jan at 09:21am EET, resolved 27 Jan at 05:25pm EET.
Authentication services
Resolved
We are happy to inform you that our team has resolved the issue! Please accept our sincerest apologies for this situation.
Posted 27 Jan at 05:25pm EET.
Updated
Our team is still working in a fix for it. Please, bear with us in this meanwhile.
Posted 27 Jan at 03:18pm EET.

Created
Some users might encounter issue with login to their accounts in MLA
Posted 27 Jan at 09:21am EET.