Back
Degraded

Browser profiles are missing
Started 24 Jan at 07:45am EET, resolved 24 Jan at 09:26pm EET.
Profile management
Resolved
The previous incident about profiles missing is now fixed, restarting the app should be enough to apply it and work just fine.
Posted 24 Jan at 09:26pm EET.

Created
Some users might have seen browser profiles missing in the Multilogin 6 app. We are look into this. Stay tuned.
Posted 24 Jan at 07:45am EET.