Back
Downtime

Server is down
Started 22 Jan at 10:47pm EET, resolved 23 Jan at 12:10am EET.
Authentication services
Resolved
We are happy to inform you that our team has resolved the issue! Please accept our sincerest apologies for this situation.
Posted 23 Jan at 12:10am EET.

Created
At this moment, we are experiencing an issue on the server side. We are working really hard to fix it.
Posted 22 Jan at 10:47pm EET.