Get in touch
Back
Degraded

Multilogin Proxies service is degraded

Started 14 Jan at 03:35pm EET, resolved 14 Jan at 04:15pm EET.

Profile Management Services
Resolved

We are happy to inform you that our team has resolved the issue! Please accept our sincerest apologies for this situation.

Posted 14 Jan at 04:15pm EET.
Created

We are currently experiencing instability with Multilogin proxies. Our team is actively investigating and working to resolve the issue as quickly as possible. We apologize for any inconvenience and appreciate your patience.

Posted 14 Jan at 03:35pm EET.