Back
Degraded

Multilogin Proxies service is degraded
Started 16 Dec at 08:30pm EET, resolved 16 Dec at 10:07pm EET.
Profile Management Services
Resolved
The issue with Multilogin proxies has been resolved, and everything is now back to normal. Thank you for your patience and understanding! If you encounter any further issues, please don't hesitate to reach out to our support team.
Posted 16 Dec at 10:07pm EET.

Created
We are currently experiencing instability with Multilogin proxies. Our team is actively investigating and working to resolve the issue as quickly as possible. We apologize for any inconvenience and appreciate your patience.
Posted 16 Dec at 08:30pm EET.