Get in touch
Back
Downtime

Billing system is down

Started 16 Oct at 02:00am EEST, resolved 16 Oct at 04:16am EEST.

Billing Services
Resolved

The billing system is back online.

Posted 16 Oct at 04:16am EEST.
Created

The billing system is not accessible right now. Our developers are working hard to resolve the issue as soon as possible.

Posted 16 Oct at 02:00am EEST.