Get in touch
Back
Resolved

Multilogin X struggles to operate on server side

Started .

Website Services API & Automation Services
Created

Dear users, we're facing some issues on MLX backend side, you may face temporary outages and probably won't be able to login to MLX for a while.
Our team is working on it, the issue will be resolved soon.

Posted .