Get in touch
Back
Resolved

Billing Systems performance degraded

Started 12 Sep at 03:21pm EEST.

Billing Services Registration services Authentication services
Created

Billing system is currently experiencing slow execution time / local outages for some users. Our team is already informed and the issue will be resolved shortly.

Posted 12 Sep at 03:21pm EEST.