Get in touch
Back
Downtime

Multilogin 6 is facing some issues.

Started 23 Aug at 04:25pm EEST, resolved 23 Aug at 07:06pm EEST.

Registration services Authentication services Profile management
Resolved

A fix has been released for the issue. All services has been restored.

Posted 23 Aug at 07:06pm EEST.
Created

Some services related to Multilogin 6 are facing issues. Our team is currently investigating the root of the issue.

Posted 23 Aug at 04:25pm EEST.