Get in touch
Back
Maintenance

System Maintence

Completed 6 Aug at 06:00pm EEST.

Registration services Authentication services Profile management Collaboration services
Completed

Maintenance completed

Posted 6 Aug at 06:00pm EEST.
Started

Some Maintenance Work on the Gateway

Posted 6 Aug at 05:00pm EEST.