Get in touch
Back
Degraded

Subscription activation delay

Started 4 Jul at 08:30pm EEST, resolved 5 Jul at 03:30pm EEST.

Billing Services
Resolved

Service restored.

Posted 5 Jul at 03:30pm EEST.
Created

Subscriptions in Multilogin X are taking longer to be active. Our team is already working to fix the issue.

Posted 4 Jul at 08:30pm EEST.