Get in touch
Back
Resolved

Server is down

Started 18 Jun at 02:58am EEST.

API & Automation Services Collaboration Services Profile Management Services Fingerprint Services Registration services Authentication services Profile management
Created

All services are up and running.

Posted 18 Jun at 02:58am EEST.