Get in touch
Back
Maintenance

Billing Release

Completed 28 May at 10:29am EEST.

Billing Services
Completed

Maintenance completed

Posted 28 May at 10:29am EEST.
Started

We are planning to release new Billing version. You can expect some disruptions.

Posted 28 May at 09:30am EEST.