Get in touch
Back
Downtime

Multilogin proxy is not able to be used

Started 25 May at 12:00pm EEST, resolved 25 May at 04:00pm EEST.

Profile Management Services
Resolved

We have identified the root cause of the issue. It was resolved. Thank you for you patience!

Posted 25 May at 04:00pm EEST.
Created

Multilogin proxy is not available to be used due to the downtime

Posted 25 May at 12:00pm EEST.