Get in touch
Back
Maintenance

Billing Release

Completed 9 Apr at 11:00am EEST.

Billing Services
Completed

Maintenance completed

Posted 9 Apr at 11:00am EEST.
Started

We are planning to release new Billing version. You can expect some disruptions.

Posted 9 Apr at 10:00am EEST.