Get in touch
Back
Degraded

Users are facing problems to launch profiles

Started 1 Feb at 10:10pm EET, resolved 1 Feb at 11:05pm EET.

Profile Management Services
Resolved

Our development team has successfully stabilized the platform, profiles can now be launched again. We will continue to monitor.

Posted 1 Feb at 11:05pm EET.
Created

Our users are currently experiencing difficulties when attempting to launch profiles in Multilogin X. Our team is already working to solve this problem.

Posted 1 Feb at 10:10pm EET.