Get in touch
Back
Downtime

Server is down

Started 10 Feb at 10:20am EET, resolved 10 Feb at 10:33am EET.

Resolved

All services are up and running now.

Posted 10 Feb at 10:33am EET.
Created

Certain users may experience service instabilities right now. Our dev team is working hard to resolve them as soon as possible. Please accept our sincere apologies for all the troubles! We appreciate your patience and understanding.

Posted 10 Feb at 10:20am EET.