Get in touch
Back
Maintenance

Multilogin maintenance on Feb 4th

Completed 4 Feb at 12:00pm EET.

Updated

We have completed the maintenance works! The application is stable now.

But if you encounter any issues, please contact us via live chat or at our email support@multilogin.com, we will be happy to assist you!

Posted 4 Feb at 12:02pm EET.
Completed

Maintenance completed

Posted 4 Feb at 12:00pm EET.
Updated

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Posted 4 Feb at 07:10am EET.
Started

Our Platform team will perform an essential Multilogin maintenance which will strengthen stability for everyone, and especially our automation users.

When will it happen: February 4th at 7 AM (GMT +2) and it will last for 4–5 hours.

How will it affect me?
During this period, the app will be inaccessible to some users: you will not be able to use Multilogin if you did not complete the maintenance process earlier.

Will it affect me?
Did you receive an email during 2022 requesting to stop using the app for 15–30 minutes on a specific day for a maintenance?
- If you did, but the recommendations were not followed, your account will be affected.
- If you did, the recommendations were followed, and you received a successful email confirmation, your account will not be affected, and you will be able to use Multilogin without any interruptions.
- If you did not receive a similar email before, your account will be affected.

If your account is affected, and you would like to avoid the maintenance on Saturday, let our Support team know which date and time will work better for you.

Please accept our most sincere apologies for this work interruption. We are performing this maintenance in order to make our service even better.

In case of any questions, please contact us via live chat (it is available on our website and the billing panel) or at support@multilogin.com, and we will be more than happy to help!

Posted 4 Feb at 07:00am EET.