Get in touch
Back
Maintenance

Scheduled Billing Database Maintenance

Completed 21 Dec at 12:00pm EET.

Updated

We have completed billing database maintenance works! The billing system is stable now.

But if you encounter any issues, please contact us via live chat or at our email support@multilogin.com, we will be happy to assist you!

Posted 21 Dec at 12:10pm EET.
Completed

Maintenance completed

Posted 21 Dec at 12:00pm EET.
Updated

Scheduled billing database maintenance is currently still in progress and requires a bit more time.

Please accept our most sincere apologies for the temporary work interruption!

When we complete it, we will let you know.

Posted 21 Dec at 11:35am EET.
Updated

Scheduled billing database maintenance is currently in progress. We will provide updates as necessary.

Posted 21 Dec at 10:14am EET.
Started

Between this Wednesday 2022-12-21 10:00 UTC+2 and Wednesday 2022-12-21 11:00 UTC+2, we will have planned maintenance works to our billing database.

During the maintenance, the billing system will be down for up to 1 hour.

Posted 21 Dec at 10:00am EET.