Get in touch
Back
Downtime

Profile management service is partialy down

Started 1 Dec at 08:14am EET, resolved 1 Dec at 05:35pm EET.

Resolved

We are happy to inform you that our team has resolved the issue with launching, creating, editing or updating browser profiles! Please accept our sincerest apologies for this situation!

Posted 1 Dec at 05:35pm EET.
Created

There are issues with launching, creating, editing or updating browser profiles.

Posted 1 Dec at 08:14am EET.