Get in touch
Back
Downtime

Billing system is down

Started 3 Nov at 09:55am EET, resolved 3 Nov at 11:04am EET.

Resolved

Our billing system access has been restored. Please accept our apologies for the inconvenience caused!

Posted 3 Nov at 11:04am EET.
Created

The billing system is not accessible right now. Our dev team is working hard to resolve them as soon as possible.

Posted 3 Nov at 09:55am EET.